AdWords が「Google 広告」になりました。これまで AdWords としてご利用いただいていたサービスの名前が「Google 広告」に変わりました。検索ネットワーク、ディスプレイ ネットワーク、YouTube などを対象にあらゆる広告サービスを提供いたします。詳細

163 人が現在オンライン
163 人が現在オンライン
Google アナリティクスのアカウント設定、プロパティ、ビューやフィルタ設定などについて、ユーザー同士で意見交換ができます。解析を通して浮かんだ質問やアイディアを投げかけ合って、よりデータ分析の知識を高めていきましょう。
ガイドを表示
star_border
返信

httpsに移行したらアナリティクスが正常に測定されていません

OKI
上級者 ✭

8/31にサイト全体をhttp→httpsに移行しました。

その後、9/5からアナリティクスが正常に測定されなくなりました。

セッション数がそれまで1日1500~2000くらいだったのですが、9/5に68、9/6以降は4とか1になっています。

・アナリティクスの設定を変更する必要があるのかと思い、

 https://webledge-blog.com/ssl-google-analytics/

 を参考にアナリティクスのプロパティ設定とビュー設定を変更しました

 

・上記と一緒にサーチコンソールも上記を参考に設定しました。

 サーチコンソールは普通に測定されていてhttpsのサーチコンソールも

 徐々に表示数が増えていっています。

 なので別にgoogleに表示されなくなったというわけではなくアナリティクスの設定の問題 

 だと思いました、

 

・アナリティクスのタグを設定するのにgoogleタグマネージャーを使っていたことを思い出し

 タグマネージャーの設定を確認してみました。

 すると、アナリティクスのタグが表示されるトリガーとして

 「先頭が一致 http://私のサイトアドレス/」

 になっていました。

 なので上記のトリガーに「先頭が一致 https://私のサイトアドレス/」を追加しました。

 

・そう言えばタグが配信されているかどうかを確認するために、タグマネージャーの

 プレビューモードという機能があったことを思い出しました。

 さっそくプレビューモードで調べてみると、アナリティクスのタグは配信されていました。

 プロパティは下記のようになっていました。

 

「私のサイト名 アナリティクスタグ
Properties

Name Value
Type Universal Analytics
Account 'UA-********-1' ←私のアナリティクスのアカウントIDと同じである確認をしました
Allow Linker false
Anonymize IP false
Content Group {}
Debug false
Decorate Forms Auto Link false
Dimension {}
Fields to Set {}
Link ID false
Metric {}
Use Hash false」

 

・上記の確認してからすでに2日ほど経つのですが、

 未だにアナリティクスは正常に測定されていません。

 

 ほかにどこを見直したらよいのかわかりません。

どなたかアナリティクスが正常に表示されていない原因・対処法がわかる方がいらっしゃいましたら教えていただければ幸いです。

1 件の受理された解決策

受理された解決策
ベストアンサーのマーク済み.
解決策
トピック作成者OKIさんが付与
9月

Re: httpsに移行したらアナリティクスが正常に測定されていません

OKI
上級者 ✭
すいません。
自分で解決できました。
トリガーの設定を変更する際にhttp://のURLを残したまま、https://のURLを追加していました。
トリガーの設定のページを見ていると
「イベント発生時にこれらすべての条件が true の場合にこのトリガーを配信します」
と書かれていたのでhttp://の方を削除した所、正常に測定されるようになりました。
お騒がせしました。

元の投稿で解決策を見る

Re: httpsに移行したらアナリティクスが正常に測定されていません

レジェンド
こんにちは。

Search Consoleではなく、実際にスマホなどで検索して、そのサイトを表示、そして
Googleアナリティクスのリアルタイムで確認、そうしますとちゃんと反映していますでしょうか?

もしそれで反映しているとしましたら、ちょっと個別に事情を探ってみないとなんとも
難しいかもしれません。

いっぽうで、リアルタイムに出ていないようであれば、スマホでのタグ発行の状況を確認したり
(ブラウザでスマホのようにアクセスできる技術はネットなどで調べますと出てきます)、
ビーコンが飛んでいるのか、フィルタはどうなっているのか、など1つ1つ調べることになるかと
思います。

私見ですが、GTMのプレビューモードでタグが発行されているということですが、まず
ビーコンを確認して実際の送信を確認(以下URLのビーコンの節に詳細)する、または
httpからhttpsへのリダイレクトが機能しているかどうか、あたりを確認するかなと
思いました。

あまり具体的な回答ができずすみません。
よろしくお願い致します。
------
文責:カグア!

Re: httpsに移行したらアナリティクスが正常に測定されていません

OKI
上級者 ✭
回答ありがとうございました。

> Search Consoleではなく、実際にスマホなどで検索して、そのサイトを表示、そして
> Googleアナリティクスのリアルタイムで確認、そうしますとちゃんと反映していますでしょうか?

リアルタイムで見ても反映されていません。
スマホだけではなくてパソコンで見ても同じです。

> 私見ですが、GTMのプレビューモードでタグが発行されているということですが、まず
> ビーコンを確認して実際の送信を確認(以下URLのビーコンの節に詳細)する、または
> httpからhttpsへのリダイレクトが機能しているかどうか、あたりを確認するかなと
> 思いました。

httpからhttpsへのリダイレクトについては業者にお願いして
.htaccessを書き直してもらいました。
特に問題なくリダイレクトできていると思います

ビーコンの確認しようと思います。
「以下URLのビーコンの節に詳細」とありますがURLが書かれていません。
お手数ですがURLを教えていただければ幸いです。

ベストアンサーのマーク済み.
解決策
トピック作成者OKIさんが付与
9月

Re: httpsに移行したらアナリティクスが正常に測定されていません

OKI
上級者 ✭
すいません。
自分で解決できました。
トリガーの設定を変更する際にhttp://のURLを残したまま、https://のURLを追加していました。
トリガーの設定のページを見ていると
「イベント発生時にこれらすべての条件が true の場合にこのトリガーを配信します」
と書かれていたのでhttp://の方を削除した所、正常に測定されるようになりました。
お騒がせしました。

Re: httpsに移行したらアナリティクスが正常に測定されていません

レジェンド
失礼しました。ビーコンの確認方法はこちらです。
http://www.kagua.biz/help/config/dousakakunin.html

すみません、

>>「先頭が一致 http://私のサイトアドレス/」になっていました。
>>なので上記のトリガーに「先頭が一致 https://私のサイトアドレス/」を追加しました。
とありますが、

>>プレビューモードで調べてみると、アナリティクスのタグは配信されていました。
とあり、

>>トリガーの設定を変更する際にhttp://のURLを残したまま、https://のURLを追加していました。
>>「イベント発生時にこれらすべての条件が true の場合にこのトリガーを配信します」

となっていて、トリガーの設定は、ご質問の際にいろいろと変えられたのですかね?
「プレビューでタグが配信されていた」というところで、そもそも私もひっかかっていまして。
(Fire のほうには表示されていなかった?)

ちょっと今後のためにお教え下さい。質問者さまとの意思疎通や認識の食い違いを
防ぐために。

よろしくお願い致します。
------
文責:カグア!

Re: httpsに移行したらアナリティクスが正常に測定されていません

OKI
上級者 ✭
申し訳ありません。
googleタグマネージャーのプレビューモードの使い方を間違えておりました。

私はプレビューモードで見たときに、「私のサイト名・アナリティクスタグ」という表示があったのでてっきり配信されているものと思っていました。
トリガーの設定は9/8に変更した後、9/11に変更するまでは触っていません。

> Fire のほうには表示されていなかった?

という文章の意味がわからなかったので、調べてみたところ
https://uideal.net/blog/03/367/
を見つけました。

多分、書き込みした時点ではTags Not Fired On This Page:の方に表示されていたんだと思います。
混乱させてしまって申し訳ありませんでした。